站内搜索

本次搜索共找到结果 3 条 (用时 0.004 秒)
2017-02-09 ... 以下是Glide命令,其中大部分命令是帮助您管理工作区。glidecreate(别名init)初始化新工作区。除此之外,这会创建一个glide.yaml文件,同时试图猜测package和版本。例如,如...果你的项目使用Godep,它将使用Godep指定的版本。Glide足够智能去扫描您的代码库,检测正在使用的package,无论有没有指定其他的包管理器。$glidecreate[INFO]Genera...gopkg.in/yaml.v2[INFO]Writingconfigurationfile(glide.yaml)[INFO]WouldyoulikeGlidetohelpyoufindwaystoimproveyourglide...Seehttps://glide.sh/docs/versions/[INFO]-->Addingadditionalmetadata.Seehttps://glide.sh/docs/glide.yaml...gename]你可以通过glideget下载一个或多个包到你的vendor目录,并会自动加入到glide.yml文件中。$glidegetgithub.com/Masterminds/cookoo当使 ...
2017-02-07 ... 大家使用Glide作为包管理器。它能够自动识别Godeps的包管理,十足的很方便。本节介绍glide.yml的语义说明以及版本指定的格式。glide.yml文件glide.yml是glide包管理的配置文件。下面我们对glide...yml是glide包管理的配置文件。下面我们对glide.yml的相关元素进行说明。这里是一个完整的glide.yml文件:package:github.com/Masterminds/glidehomepage:https://masterminds...com/arschles/assert这些元素是:package:顶部的package是它所在GOPATH的位置,glide将从该位置下开始导包。homepage:该项目的详情页面。license:许可证标识,可以是SP...t:在导入中未列出的测试中使用的软件包列表。每个包具有与导入下列出的相同的详细信息。版本和范围Glide支持SemanticVersions,SemVerranges,branches,tags和commitids作为version...mmitids作为version.基本一个简单的范围格式是>1.2.3。这告诉Glide去使用1.2.3之后的最新版本。它还支持以下操作符:=:等于(可省略)!=:不等于>:大于<: ...
2016-12-24 ... 客系统的前端采用html和jquery编写,样式采用CSS。Glide,golang编写。作为博客系统的包依赖管理器,其开源地址是Glide。Docker,博客系统可docker部署,方便,快捷。Do ...